Skip to main content

Creating TASK-* RPMs for Mageia: task-codeweavers-essentials

A task-*.rpm package is a metapackage, a special type of package that installs other RPM packages that are delineated as dependencies of the task-*.rpm. They contain no actual data, they just cause the system to install  other RPM packages as directed.

There is a need to create such a package to compliment the installation of Codeweaver's crossover application. As explained in another post, Mageia is a distro unsupported by Codeweavers and has different names for the needed dependencies that are provided by Mageia. Rather than struggle through a long list of packages to install, it would be easier to invoke

$ sudo urpmi crossover-essentials-task

and be done with it.

The first step to create such a package is to build the .spec file. I chose to modify an existing .spec file, so I started with the .spec file from task-lxde. It is shown below.

 Name: task-lxde
Version: 7
Release: %mkrel 1
Epoch: 1
Summary: Metapackage for lxde
Group: Graphical desktop/Other
License: GPL
URL: http://lxde.org
# Requires: %{name}-minimal
# Requires components listed on lxde wiki,
# see: http://wiki.lxde.org/en/Status_of_LXDE_Components
Requires: gpicview
Requires: lxtask
Requires: lxinput
Requires: lxsession-edit
Requires: lxrandr
Requires: lxdm
Requires: lxpolkit
Requires: lxhotkey
# Recommends other app independent of lxde
Recommends: epdfview
Recommends: leafpad
Recommends: xarchiver
Recommends: xmessage
Recommends: task-pulseaudio
Recommends: mageiawelcome
Recommends: hexchat

BuildArch: noarch

%description
This package is a meta-package, meaning that its purpose is to contain
dependencies for running the Lightweight X11 Desktop Environment.

%package minimal
Summary: Minimal dependencies needed for LXDE
Group: Graphical desktop/Other
Requires: desktop-common-data
Requires: lxde-common
Requires: lxappearance
Requires: lxterminal
Requires: task-x11
Requires: drakconf
Requires: obconf
Requires: dbus-x11
Requires: gnome-themes-standard
Requires: adwaita-gtk2-theme

%description minimal
This package is a meta-package, meaning that its purpose is to contain
minimal dependencies for running a minimal Lightweight X11 desktop
environment.

%prep
# nothing

%build
# nothing

%install
# nothing

%files

%files minimal


%changelog
* Mon Mar 11 2019 ns80 1:7-1.mga7
+ Revision: 1373929
- use the same version number as Mageia

This spec file will build two RPM files, one of which installs only minimal dependencies. While there are other dependencies that could be installed for Crossover, those are really for specific use applications and it's not necessary to install them all to get a functional Crossover installation.

So it is modified as follows:

Name: task-crossover
Version: 1
Release: %mkrel 1
Epoch: 1
Summary: Metapackage for Codeweavers Crossover Essentials
Group: Emulators/Other
License: GPL
URL: http://Codeweavers.com
# Requires components listed on MaximumHoyt.com,
# see: https://maximumhoyt.blogspot.com/2019/10/install-codeweavers-crossover-on-mageia.html
Requires: libnss-mdns2
Requires: pygtk2.0
Requires: libfontconfig1
Requires: libmesaglu1
Requires: libsane1
Requires: libudev1
Requires: libxcomposite1
Requires: libxinerama1
Requires: libxslt1
Requires: libmesagl1
Requires: libfreetype6
requires: libpng16_16

# Recommends other app 

#Recommends: 

BuildArch: noarch

%description
This package is a meta-package, meaning that its purpose is to contain dependencies for running Codeweaver's Crossover application. It does not install Crossover. Crossover does not directly support Mageia and will not automatically install necessary dependencies, but this metapackage will.

%prep
# nothing

%build
# nothing

%install
# nothing

%files

%changelog
* Fri Nov 07 2019 hoyt 1:1-1.mga7
+ Revision: 001
- add spec file
- Created package structure for task-crossover-essentials.


Now it's time to build the package. Have a look at Packaging for Beginners and the RPM Tutorial in the Mageia Wiki.

$ cd ~/rpmbuild/SPECS
$ rpmbuild -ba task-crossover-essentials.spec

You'll find your packages in ~/rpmbuild/RPMS and ~/rpmbuild/SRPMS

RESOURCES

You can download my RPM package here, but use it at your own risk. Best to build your own. It's not that difficult.

Packaging for Beginners
https://wiki.mageia.org/en/Packaging_for_beginners

RPM Tutorial
https://wiki.mageia.org/en/Packagers_RPM_tutorial

Easy RPM Builder
https://www.pling.com/p/1127175/

Comments

Popular posts from this blog

DOS4GW.EXE Version 2.01a and Alternative DOS Extenders

DOS4GW.EXE
The TenberryDOS extender DOS4GW.EXE was used by many early DOS games. I still enjoy playing many of these games and DOS4GW.EXE is usable with DOSBox, so they can be played on Linux.

However, the version of DOS4GW.EXE that was included with the game was whatever was current at the time. The most recent version that includes many bugfixes that possibly affected the games when used with DOSBox have been fixed in the latest version, 2.01a.

It's not free at US$49, but you can downloaded it here. Simply substitute it for whatever version of DOS4GW.EXE your game provided and enjoy the bug-fixed goodness. Tenberry also makes a "high-performance" "pro" version of DOS4GW.EXE, but it costs $300. I think that they could sell quite a few of these to hobby users (since, you know, DOS is dead) for US$5.

Open Souce to the Rescue
There are better performing, free and Open Source alternatives available and worth a look.

DPMI Explained
But first, let's understand w…

Unreal Tournament GOTY/UT99 for Modern Linux

Released on November 16, 1999, Unreal Tournament (also known as UT99) is an arena first-person shooter for Multiplayer on-line competition or you cam play against bots off-line. It features several game types, with more details provided at Wikipedia. The game was re-released on February 25, 2000 as Unreal Tournament Game of the Year Edition (GOTY) which included the three bonus packs released previously and additional mods, or game modifiers that had become popular. It is the GOTY version that is available from STEAM of GOG.com.

The GOG version for Windows installs in Linux and plays well using WINE, PlayOnLinux or Codeweaver's Crossover.

There is a Linux binary available in two versions, one for the original game and one for the GOTY edition. Also provided at that site is the Official Bonus Pack with a Linux installer. All these Linux installers are created with makeself.

There are some issues using such a crusty old Linux binary. Let's see why getting a Linux binary up and …

Unpack those .EXE game files from GOG,com (Plus other un-packers)

I just came upon innoextract today. I have many of the wonderful games from GOG.com, some of which have native Linux Clients. Before now, I've had to use PlayOnLinux or Crossover to install these for use with WINE, then add the Linux client.

InnoSetup as a way to create an installer to install the games on Windows. Daniel Scharrer has created innoextract to allow the unpacking of those archives on a non-Windows platform.

The website provides information on using innoextract, but this information from the page is very useful:
GOG.com Installers GOG.com installers with a 2.x.x version number on the download page or in the filename use InnoSetup 5.5.0 and cannot be extracted by innoextract 1.2 and older. Older installers use InnoSetup 5.2.3 and usually have no version in the filename. Some GOG.com multi-part installers with version 2.1.x or higher use RAR archives (renamed to .bin) to store the game data. These files are not part of the InnoSetup installer and require unrar or unar to…